Let’s review the minimum ClassicPress requirements, recommended requirements, and some important details to keep in mind when you switch over from any existing WordPress installs, especially if you come from a WordPress version 5.0 or higher.

Minimum requirements

Recommended requirements

  • PHP version 8.0
    • PHP 8.0 support was introduced in v1.5.0. We recommend you upgrade!
    • PHP 8.1 support is in progress.
  • MySQL version 5.7 or higher or MariaDB version 10.3 or higher.
  • Apache 2.4 with mod_rewrite module, Nginx, or LiteSpeed server.
  • An SSL certificate to support HTTPS (free from Let’s Encrypt).

Switching from WordPress 5.0+

  • Make sure you are not using any plugins that require WordPress 5.0 or higher.
  • Make sure you are not using a theme that requires WordPress 5.0 or higher.
  • Make sure you are not using any code that uses WordPress functions introduced or modified in or after WordPress 5.0.
  • Sometimes, you can proceed using the above-mentioned themes or plugins, by providing “shims” for the missing Functions.